
 

YOUR FASTEST SOLUTION TO A BETTER DESIGN 

 

 

ElecNet 
Version 7.8 

Or later 

 

Electrostatic / Current Flow /  
Time-harmonic / Transient  
2D & 3D Tutorials 

 
May 31, 2017



 

We welcome your comments regarding Infolytica Corporation documents. Please send comments or 
corrections to the following addresses: 

 

email: docs@infolytica.com 

fax:  Documentation Department 
  (514) 849-4239 

post: Documentation Department 
  Infolytica Corporation 
  300 Leo Pariseau,  Suite 2222 
  Montreal, Quebec H2X 4B3 
  Canada  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

© 2017 Infolytica Corporation.  

Part number EN7-T-010 

 
All rights reserved. No part of this document may be reproduced, translated to another language, stored in a 
retrieval system, or transmitted in any form or by any means, electronic, photocopying, recording, or 
otherwise, without written permission from Infolytica Corporation. 
 
The information in this document is subject to change without notice. 



 

Introduction to the tutorials 
This document includes four tutorials to help you increase your skills with ElecNet. Each 
tutorial teaches you basic procedures that you can apply to your own models.  

2D Tutorials 
Translational geometry 

 Electrostatic solution: Spheres 

 Current Flow solution: Conductance of a trimmed resistor 

 Time-harmonic and Transient solution: Microstrip 

3D Tutorials 

 Electrostatic and Transient solution: Microstrip 

Additional information 

The Getting Started Guide introduces you to the basic ElecNet concepts. More 
information on the procedures and concepts of model building with ElecNet is found in 
the Help, included with each package, and in the Live Docs section of our web site. 



 

Features showcase 
Tutorial #1 
2D Electrostatic solution: Spheres  
 

Features you will learn 

 Setting up the work environment by modifying initial settings, the 
construction grid, and the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 

 Setting up the problem - this consists of making components, electrodes, and 
assigning boundary conditions. 

 Generating the electrostatic field solution using ElecNet’s 2D Electrostatic 
solver. 

 Analyzing the results: this includes viewing the stored electric energy and 
charge of the model, the shaded plot of |E|, and the contour of V. 

 Probing local fields at specific locations using the Field Line Graph feature. 

Tutorial #2 
2D Current Flow solution: Conductance of a trimmed resistor 
 

Features you will learn 

 Setting up the work environment by modifying initial settings, the 
construction grid, and the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 

 Setting up the problem - this consists of creating a new material, and of 
making components and electrodes. 

 Generating the current flow field solution using ElecNet’s 2D Current Flow 
solver. 

 Analyzing the results: this includes viewing the power of the model, the 
current of the electrodes, the shaded plot of |E|, and the contours of V. 

 Probing local fields at specific locations using the Field Line Graph feature. 



 

Tutorial #3 
2D Time-harmonic and Transient solution: Microstrip 
 

Features you will learn 

 Setting up the work environment by modifying initial settings, the 
construction grid, and the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 

 Setting up the problem - this consists of making components and electrodes, 
using parameterization, and assigning boundary conditions. 

 Modifying the model so as to obtain the desired solution results. 

 Generating the time-harmonic field solution using ElecNet’s 2D Time-
harmonic solver. 

 Generating the transient field solution using ElecNet’s 2D Transient solver. 

 Analyzing the results: this includes viewing the contours of V at 0’, animating 
the voltage contour field plot, and graphing the conduction and displacement 
current as a function of frequency and time. 

Tutorial #4 
3D Electrostatic and Transient solution: Microstrip 
 

Features you will learn 

 Setting up the work environment by modifying initial settings, the 
construction grid, and the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 

 Setting up the problem - this consists of making components and electrodes, 
and assigning boundary conditions. 

 Modifying the model so as to obtain the desired solution results. 

 Generating the electrostatic and transient field solution using ElecNet’s 3D 
Electrostatic and Transient solvers. 

 Generating streamlines using Infolytica’s Streamline Generator extension. 

 Analyzing the results: this includes viewing the contours of V and the shaded 
plot of |E| smoothed, from two viewing perspectives (Z=0 and X=500). 
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2D Electrostatic Tutorial 
Spheres 
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Modeling plan 

This problem is axisymmetric. Axisymmetric electric field problems usually have the axis itself 
unconstrained. Like axisymmetric magnetic field problems, only the model to the right of the axis 
is drawn. The boundaries can be nearer than in a Cartesian problem, simply because the field 
values fall as a 1/distance3, not 1/distance2. Commonly the potentials are specified on the device 
itself, with the boundaries set to Flux Tangential or Ground. The solver produces a set of scalar 
potentials as a solution. 

In this example, as discussed above, the boundaries are Flux Tangential, except for the mid 
conducting plane set to Ground. It deals with the breakdown voltage between two spheres. The 
results match up neatly with experimental work in the laboratory. As a check of the computational 
method, it is instructive to calculate capacitance and attractive force between two spheres, and 
compare with published work. The figure shows a typical sphere-gap arrangement. The experiment 
establishes the relationship between breakdown voltage and sphere spacing and diameter. It is 
instructive for the student of high voltage to perform the real test in the laboratory, and then 
simulate it using a CAD package. 

According to BBS, the voltage at breakdown is 131 kV rms. The peak value is thus 185 kV. We 
will apply this potential difference between the spheres and use ElecNet to calculate the maximum 
electric field strength (potential gradient) at breakdown. 

Creating a new model 

Opening a new model 

 From your desktop, double-click the ElecNet icon. 

The Main window appears. 
or 

 If ElecNet is already running, on the File menu, click New to open a new model. 

Name the model 

By default, ElecNet assigns a name to the model (e.g., ElecNet1) every time a new model is 
opened. As long as the application remains open, each new model number increments by one (e.g., 
if the new model you have opened is the fourth one in this session, ElecNet would assign the name 
ElecNet4). You can choose to retain this name, although it is recommended that you give the 
model a distinct name. 

1. On the File menu, click Save As. 
2. In the Save As dialog box, enter Sphere as the name of the model. 
3. Choose the drive and directory where you want to place the model. 
4. Click Save As. 
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Setting up the working environment 

Initial Settings 

Each new model reverts to the ElecNet default settings for the meshing method, preferred units for 
length, time and frequency, and for how curves will be displayed in the view. For our model, we 
are going to change only the preferred unit for length and accept all the other defaults. 

1. From the Object page, select the model. 
2. On the Edit menu, click Properties. 
3. Click the Units tab and then from the Length drop down list, select Millimeters. 
4. Click OK. 

Set view to update automatically 

Use of this feature resets the view automatically to include all of the model’s geometry, as it is 
being drawn. 

 On the View menu, click Update Automatically. 

 

Build the geometric model 
For the example chosen, the sphere is 62.5 mm in diameter. Since the problem has a plane of 
symmetry, it is possible to model only the upper sphere and half the air gap as shown, where the 
arc represents the sphere. Thus, the center is (31.25 +30) mm above the plane. The interior of the 
sphere need not be modeled. 
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Draw the geometric model of the components 
1. On the Tools menu, click Keyboard Input Bar. 
2. On the Draw menu, click Arc (Center, Start, End). 
3. In the Keyboard Input bar, enter the following coordinates to draw the sphere: 

Center coordinates 0, 61.25 Press ENTER 

Start coordinates 0, 30 Press ENTER 

End coordinates 0, 92.5 Press ENTER 

4. On the Draw menu, click Line. 
5. In the Keyboard Input bar, enter the following coordinates to draw the air box: 

Start coordinates 0, 30 Press ENTER 

End coordinates 0, 0 Press ENTER 

End coordinates 200, 0 Press ENTER 

End coordinates 200, 300 Press ENTER 

End coordinates 0, 300 Press ENTER 

End coordinates 0, 92.5 Press ENTER 

6. Press ESC. 
 

Setting up the problem 
Make the component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the region between the outer arc and the boundary. 
3. On the Model menu, click Make Component in an Arc, and enter the following values: 

Name:     Air box 
Material:  AIR 
Angle:    -90 degrees 

4. Click OK. 

Make an electrode using the sphere 
1. On the Edit menu, click Select Component Surfaces. 
2. Select the half circle region, which represents the sphere surface. 
3. On the Model menu, click Make Electrode. 
4. In the Object page, select Electrode #1. 
5. On the Edit menu, click Properties and modify Electrode#1 to read: 

Name:    Electrode (Sphere) 
6. Select the Waveform tab and enter the following values for ACDC: 

Magnitude (RMS): 92500 
Phase (Deg):               0  

7. Click OK. 
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Assign boundary conditions 
1. In the Object page, select Face#3 of the Air box component. 

The surface of the bottom face is selected. 
2. On the Boundary menu, click Ground. 
 

Generating the electrostatic field solution 
Set the solving options 
1. On the Solve menu, click Set Solver Options, and verify that the following values are set: 

Material type:  Non-linear 
Method:  Newton-Raphson 
Max. Newton iterations:  20 
Newton tolerance:  1 % 
Polynomial order: Default (Note   for axisymmetrical models the default is 2) 
CG tolerance: 0.01 % 
Source frequency:  60 Hertz 

Note CG Tolerance is the only value that has any significance for this electrostatic 
solution. All other values are listed for information purposes only. 

2. Click OK. 
3. On the Solve menu, click Static 2D. 
 

Analyzing the results 
In this section, the following results are viewed: 

 Stored electric energy of model 

 Charge on electrode 

 Shaded plot of |E| on the lowest part of the arc and the lower left hand corner surface of the 
model 

 Contours of V 



   Tutorial #1                          2D Electrostatic Tutorial   5 

Spheres    

© 2017 Infolytica Corporation 

View the energy and charge 

The Results window is automatically displayed when the Solver Progress dialog closes and the 
solution is complete. 

 

1. Verify that the value for Stored Electric Energy is 0.0187577071674261 Joules. 
2. Select the “Charge” tab. 

The Charge page is displayed. 
3. Verify that the value for Charge is 4.0557204686326703e-007 Coulombs. 
4. The capacitance between the spheres is simply the charge divided by the potential difference 

between them (i.e., 4.0557204686326703e-007/185x10e3 = 2.192pF). As a comparison, the 
analytical result is 2.3487 pF.  

Note To reduce the error in ElecNet’s value, use adaption or a higher polynomial order. 
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View the shaded plot of |E| 

First, we will magnify the area of the model we want to place focus on, and then update the view 
to display the shaded plot of |E| for this area. 

1. Before viewing the shaded plot, switch back to the View window by clicking the View tab 

 located at the bottom of the window. 

2. On the View toolbar, click  (Examine Model). 
3. Hold down the CTRL key and left mouse button, and then drag the cursor down and across the 

lowest part of the arc and the lower left hand corner, releasing the button once the desired area 
is selected. 

4. From the Project Bar, select the “Field” page, and then click the tab labelled “Contour”. 
5. In the “Fields to Display” box, select None. 
6. Click the tab labelled “Shaded”. 
7. In the “Fields to Display” box, select |E|. 
8. At the bottom of the “Field” page, click Update View. 

The shaded plot is displayed.  

 

Note The maximum value of |E| (4.5124e+006 V/m) is just below the sphere. 
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View the contours of V 

Here, we want to reset the viewing area so that the whole model is visible, and then update the 
view to display the contours of V. 

1. On the View menu, click View All. 
2. In the “Fields to Display” box for the shaded plot, select None. 
3. On the “Field” page, click the tab labelled “Contour”. 
4. In the “Fields to Display” box, select V. 
5. At the bottom of the Field page, click Update View. 

The contour is displayed. 
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Plotting V on a graph using the Field Contour Graphs feature 

In this procedure we are going to use the ElecNet post-processing feature (Field Line Graph) that 
allows us to define a line segment, extract the 1000 field values along that segment, and then plot 
the field quantities on a graph.  

 

Note Although not shown in this procedure, Field Arc Graph and Field Circle Graph are 
also available for post-processing. Please refer to the Help for more information. 

1. On the Tools menu, click Field Line Graph. 
2. In the Keyboard Input bar, enter the coordinates (0,0) and (0,30), pressing Enter after each set 

of numbers. 

Note If you prefer, you can also use the mouse to draw the line graphically. 

3. The graph is automatically displayed in a new Graph window.  
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Save the model 

You have now completed the 2D Electrostatic tutorial. 

1. On the File menu, click Save. 
2. On the File menu, click Close. 

Summary 

In this tutorial, you completed the steps in creating a sphere model for an electrostatic solution. 
The skills you learned include: 

 Setting up the work environment by modifying initial settings and the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 

 Setting up the problem -- this consists of making components, electrodes, and assigning 
boundary conditions. 

 Generating the electrostatic field solution using ElecNet’s 2D Electrostatic solver. 

 Analyzing the results, that includes viewing the stored electric energy and charge of the 
model, the shaded plot of |E|, and the contour of V. 

 Probing local fields at specific locations using the Field Line Graph. 
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2D Current Flow Tutorial 
Conductance of a trimmed resistor 
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Modeling plan 

This problem consists of calculating the conductance of the shape shown below. It is a rectangle 
with a cut half way across it. The rectangle is 6 mm high, 10 mm long, with a slot 2 mm wide 
cutting half way across. Since the conductance per meter depth is totally independent of the 
units, it is only the ratio of the x and y dimensions that is important here. 

The electric field E is the gradient of a scalar potential V. 

 

Creating a new model 

Opening a new model 

 From your desktop, double-click the ElecNet icon. 

The Main window appears. 
or 

 If ElecNet is already running, on the File menu, click New to open a new model. 

Name the model 

By default, ElecNet assigns a name to the model (e.g., ElecNet1) every time a new model is 
opened. As long as the application remains open, each new model number increments by one 
(e.g., if the new model you have opened is the fourth one in this session, ElecNet would assign 
the name ElecNet4). You can choose to retain this name, although it is recommended that you 
give the model a distinct name. 

1. On the File menu, click Save As. 
2. In the Save As dialog box, enter Trim resistor as the name of the model. 
3. Choose the drive and directory where you want to place the model. 
4. Click Save As. 
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Setting up the working environment 

Initial Settings 

Each new model reverts to the ElecNet default settings for the meshing method, preferred units 
for length, time and frequency, and for how curves will be displayed in the view. For our model, 
we are going to change only the preferred unit for length and accept all the other defaults. 

1. From the Object page, select the model. 
2. On the Edit menu, click Properties. 
3. Click the Units tab and then from the Length drop down list, select Millimeters. 
4. Click OK. 

Setting the construction grid 
1. On the View menu, click Construction Grid. 

A check mark next to the menu item indicates that it is enabled. 
2. On the View menu, click Set Construction Grid. 
3. In the Set Grid Extent and Spacing dialog, enter the following values: 

Minimum X:  -1 Maximum X: 11 
Minimum Y:  -1 Maximum Y:  9 
X spacing:  1 Y spacing:  1 

4. Click OK. 

Set view to update automatically 

Use of this feature resets the view automatically to include all of the model’s geometry, as it is 
being drawn. 

 On the View menu, click Update Automatically. 

Build the geometric model 

Draw the geometric model of the component 
1. On the Tools menu, click Keyboard Input Bar. 
2. On the Draw menu, click Line. 
3. In the Keyboard Input bar, enter the following coordinates to draw the conductor: 

Start coordinates 0, 6 Press ENTER 
End coordinates 0, 0 Press ENTER 
End coordinates 10, 0 Press ENTER 
End coordinates 10, 6 Press ENTER 
End coordinates 6, 6 Press ENTER 
End coordinates 6, 3 Press ENTER 
End coordinates 4, 3 Press ENTER 
End coordinates 4, 6 Press ENTER 
End coordinates 0, 6 Press ENTER 

4. Press ESC. 
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Setting up the problem 

Create a new material 

For the purposes of this tutorial, we need to assign a resistive material to the component we have 
just drawn. Since this type of material does not exist in the Material library, we will create a new 
material and save it to the database. 

1. On the Tools menu, click New User Material. 
2. On the General page, enter the following data: 

 Name: Resistive Material 

 Display color: Click Display Color and select an appropriate color 

 Transparency: Optional 

 Description: Optional 

 Categories: Optional 

3. Click Next. 
4. On the Options page, select the following: 

 Magnetic Permeability 

 Electric Conductivity 

5. Using the Next button to advance to the appropriate pages, enter the following values: 

 Temperature Celsius = 20 

 Relative Permeability = 1 

 Coercivity Amps/m = 0 

 Conductivity Siemens/m = 10 

6. Once you have entered all the values, click Finish in the Confirmation page to create the new 
material. 

7. On the File menu, click Save. 

Make the component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name: Conductor 

 Material: Resistive Material 

 Distance: 1 Millimeter 

4. Click OK. 
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Making the electrodes 

 

1. On the View menu, click  (Examine Model). 
2. Holding down the left mouse button, place the cursor over the model and rotate it so that it 

appears as the illustration above. 
3. In the Object page, select Face#4 of the Conductor component. 
4. On the Model menu, click Make Electrode. 
5. In the Object page, select Face#10 of the Conductor component. 
6. On the Model menu, click Make Electrode. 
7. In the Object page, select Electrode #2. 
8. On the Edit menu, click Properties and select the Waveform tab. 
9. Enter the following values for ACDC: 

 Magnitude (RMS): 1 

 Phase (Deg):      0  

10. Click OK. 

Generating the current flow field solution 
Set the solving options 
1. On the Solve menu, click Set Solver Options, and enter (if necessary) the following values: 

 Material type: Linear 
 CG Tolerance: 0.01 
 Source frequency: 60 Hertz 

2. Click OK. 

Solve the model 

 On the Solve menu, click Current Flow 2D. 

The ElecNet Current Flow 2D Solver Progress dialog appears momentarily and then the 
Results page opens. 
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Analyzing the results 
In this section, the following results are viewed: 

 Ohmic loss 

 Current on electrode 

 Shaded plot of |E| of the model 

 Contours of V 

View the ohmic loss and current 

The Results window is automatically displayed when the Solver Progress dialog closes and the 
solution is complete. 

 

1. Verify that the value for Ohmic Loss is 0.00415024906025684 Watts. 
2. Select the Conduction Current tab. 
3. Verify that the values for each electrode is as follows: 

 Electrode#1 -0.00415024906025684 Amperes 

 Electrode#2  0.00415024906025684 Amperes 
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View the shaded plot of |E| 
1. Before viewing the shaded plot, switch back to the View window by clicking the View tab 

 located at the bottom of the window. 
2. From the Project Bar, select the “Field” page, and then click the tab labelled “Contour”. 
3. In the “Fields to Display” box, select None. 
4. Click the tab labelled “Shaded”. 
5. In the “Fields to Display” box, select |E|. 
6. At the bottom of the Field page, click Update View. 

The shaded plot is displayed. 

 

View the contour of V 
1. In the “Fields to Display” box of the Shaded tab, select None. 
2. Click the tab labelled “Contour”. 
3. In the “Fields to Display” box, select V. 
4. At the bottom of the Field page, Click Update View. 

The contour is displayed.  
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Plotting V on a graph using the Field Contour Graphs feature 

In this procedure we are going to use the ElecNet post-processing feature (Field Line Graph) that 
allows us to define a line segment, extract the 1000 field values along that segment, and then plot 
the field quantities on a graph.  

 

Note Although not shown in this procedure, Field Arc Graph and Field Circle Graph 
are also available for post-processing. Please refer to the Help for more 
information. 

1. On the Tools menu, click Field Line Graph. 
2. In the Keyboard Input bar, enter the coordinates (0, 0) and (10, 0), pressing Enter after each 

set of numbers. 

Note If you prefer, you can also use the mouse to draw the line graphically. 

3. The graph is automatically displayed in a new window.   
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Save the model 

You have now completed the 2D Current Flow tutorial. 

1. On the File menu, click Save. 
2. On the File menu, click Close. 

Summary 

In this tutorial, you completed the steps in creating a Trim Resistor model for a current flow 
solution. The skills you learned include: 

 Setting up the work environment by modifying initial settings, the construction grid, and 
the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 

 Setting up the problem -- this consists of creating a new material, and of making 
components and electrodes. 

 Generating the current flow field solution using ElecNet’s 2D Current Flow solver. 

 Analyzing the results, which includes viewing the ohmic loss of the model, the current of 
the electrodes, the shaded plot of |E|, and the contours of V. 

 Probing local fields at specific locations using the Field Line Graph feature. 
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Modeling plan 

 

Creating a new model 

Opening a new model 
 From your desktop, double-click the ElecNet icon. 

The Main window appears. 
or 

 If ElecNet is already running, on the File menu, click New to open a new model. 

Name the model 

By default, ElecNet assigns a name to the model (e.g., ElecNet1) every time a new model is 
opened. As long as the application remains open, each new model number increments by one 
(e.g., if the new model you have opened is the fourth one in this session, ElecNet would assign 
the name ElecNet4). You can choose to retain this name, although it is recommended that you 
give the model a distinct name. 

1. On the File menu, click Save As. 
2. In the Save As dialog box, enter TH-Microstrip as the name of the model. 
3. Choose the drive and directory where you want to place the model. 
4. Click Save As. 
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Setting up the working environment 

Initial Settings 

Each new model reverts to the ElecNet default settings for the meshing method, preferred units 
for length, time and frequency, and for how curves will be displayed in the view. For our model, 
we are going to change only the preferred unit for length and accept all the other defaults. 

1. On the Tools menu, click Set Units. 
2. From the Length drop down list, select Millimeters. 
3. Click OK. 

Set view to update automatically 

Use of this feature resets the view automatically to include all of the model’s geometry, as it is 
being drawn. 
 On the View menu, click Update Automatically. 

Build the geometric model and set up the problem for the 
dielectric board component 
Create a new material 

For the purposes of this tutorial, we need to assign a material that does not exist in the Material 
library. We will create a new material and save it to the database. 

1. On the Tools menu, click New User Material. 
2. On the General page, enter the following data: 

 Name: Diel 
 Display color: Click Display Color and select an appropriate color 
 Transparency: Optional 
 Description: Optional 
 Categories: Optional 

3. Click Next. 
4. On the Options page, select the following: 

 Electric Conductivity 
 Electric Permittivity 

5. Using the Next button to advance to the appropriate pages, enter the following values: 

 Temperature Celsius = 20 
 Conductivity Siemens/m = 1e-4 
 Conductivity %IACS = 1.72e-010 (Automatic) 
          Note  Conductivity value entered in one unit will be  
                    automatically reflected in the other unit. 
 Relative Permittivity = 2 

6. Once you have entered all the values, click Finish in the Confirmation page to create the new 
material. 

7. On the File menu, click Save. 
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Draw the dielectric board component 
1. On the Tools menu, click Keyboard Input Bar. 
2. On the Draw menu, click Line. 
3. In the Keyboard Input bar, enter the following coordinates to draw the board: 

Start coordinates 0, 0 Press ENTER 

End coordinates 20, 0 Press ENTER 

End coordinates 20, 5 Press ENTER 

End coordinates 0, 5 Press ENTER 

End coordinates 0, 0 Press ENTER 

4. Press ESC. 

Make the dielectric board component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name:    Dielectric board 

 Material: Diel 

 Distance: 1 Millimeters 

4. Click OK. 

Assign boundary conditions to the dielectric board 

 

1. On the View menu, click Wireframe Model. 

2. On the View menu, click  (Examine Model Dynamically). 
3. Holding down the left mouse button, place the cursor over the model and rotate it so that it 

appears as the illustration above. 
4. On the Edit menu, click Select Component Surfaces. 
5. Expand the faces of the Dielectric board by clicking the + sign. 
6. In the Object page, select Face#3 of the Dielectric Board component. 

The bottom surface of the dielectric board is highlighted. 
7. On the Boundary menu, click Ground. 
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Build the geometric model and set up the problem for the air 
box component 

Draw the air box component 
1. On the View menu, click Preset Views, and then Positive Z Axis. 
2. On the Draw menu, click Line. 
3. On the View menu, click Update Automatically. 
4. In the Keyboard Input bar, enter the following coordinates to draw the air box: 

Start coordinates 0, 5 Press ENTER 

End coordinates 20, 5 Press ENTER 

End coordinates 20, 40 Press ENTER 

End coordinates 0, 40 Press ENTER 

End coordinates 0, 5 Press ENTER 

5. Press ESC. 

Make the air box component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name:   Air box 
 Material: AIR 
 Distance: 1 Millimeters 

4. Click OK. 

Build the geometric model and set up the problem for the 
microstrip component 
Draw the microstrip component 

1. On the View menu, click  (Examine Model Dynamically). 
2. Hold down the CTRL key and left mouse button, and then drag the cursor to form a rectangle 

(around the bottom left corner of the air box and the top left corner of the dielectric board), 
releasing the button once the desired area is selected. 

3. On the Draw menu, click Line. 
4. In the Keyboard Input bar, enter the following coordinates to draw the microstrip: 

Start coordinates 0, 5 Press ENTER 

End coordinates 0.5, 5 Press ENTER 

End coordinates 0.5, 5.25 Press ENTER 

End coordinates 0, 5.25 Press ENTER 

End coordinates 0, 5 Press ENTER 

5. Press ESC. 
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Make the microstrip component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name:     Microstrip 

 Material: Copper: 5.77e7 Siemens/meter 

 Distance: 1 Millimeters 

4. Click OK. 

Make an electrode 

 

1. In the Object page, select Microstrip component. 
2. On the Model menu, click Make Electrode. 
3. In the Object page, select Electrode #1. 
4. On the Edit menu, click Properties and modify Electrode#1 to read: 

 Name:    Electrode (Strip) 

5. Select the Waveform tab and enter the following values for ACDC: 

 Magnitude (RMS): 1 
Phase (Deg):       0  

6. Click OK. 

Modifying the model prior to solving 
Modify the mesh 

In the 2D finite element method of analysis, the model is divided into a mesh of triangular-
shaped elements. The accuracy of the solution depends upon the nature of the field and the size 
of the mesh elements. In regions where the direction or magnitude of the field is changing 
rapidly, high accuracy requires small elements. One method of increasing mesh density is to set 
the maximum element size for a component volume or specific faces of a component. The 
following procedures will demonstrate this method. 
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View the initial mesh 

Before changing the maximum element size, the default initial mesh can be viewed.  

1. On the View menu, click Update Automatically. 
2. On the View menu, click Initial 2D Mesh. 

The initial mesh appears in the View window.  

 

3. On the View menu, click Solid Model.  

Set the maximum element size for each component 
1. In the Object page of the Project bar, select the Dielectric board component. 

 

2. On the Edit menu, click Properties. 
The Dielectric board Properties dialog appears. 

3. Select the Mesh tab. 
4. Click inside the Maximum element size checkbox, and then type 1.5 in the text box. 
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5. Click Apply. 

Tip Clicking Apply, instead of OK, keeps the dialog open and allows us to proceed to 
the next component without having to repeat steps 2 and 3. 

6. In the Object page, select the Air box component. 
Notice that the text in the Properties dialog Title Bar has now changed to read  
Air box Properties.  

7. Click inside the Maximum element size checkbox, and then type 3 in the text box. 
8. Click Apply. 
9. In the Object page, select the Microstrip component. 
10. Click inside the Maximum element size checkbox, and then type 0.1 in the text box. 
11. Click OK. 

View the changes to the mesh 

1. On the View menu, click Initial 2D Mesh. 
The modified initial mesh appears in the View window and should look similar to the 
following illustration, on the right. 

Before      After  

2. On the View menu, click Solid Model. 
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Generating the time-harmonic field solution 

Set the solving options 

 

1. On the Solve menu, click Set Solver Options, and verify that the following values are set: 

 Material type:  Default 

 Method: Newton-Raphson 

 Maximum Newton iterations: 20 

 Newton tolerance: 1% 

 Polynomial order: 2 

 CG tolerance: 0.01% 

 Source frequency: 1e5 Hertz 

2.  Click OK. 

Solve the model 
 On the Solve menu, click Time Harmonic 2D. 

The ElecNet Time-Harmonic 2D Solver Progress dialog appears briefly and then the Results 
window opens. 
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Analyzing the results 
View the contours of V at 0’  
1. Before viewing the contour plot, switch back to the View window by clicking the View tab 

 located at the bottom of the window. 
2. From the Project Bar, select the “Field” page. 

The page appears with the Contour tab selected. 
3. In the “Fields to Display” box, select V at 0’. 
4. Select the “Shaded” tab. 
5. In the “Fields to Display” box, select None. 
6. At the bottom of the Field page, click Update View. 

The contour plot of V at 0’ field is displayed. 

 

Calculate the capacitance between the electrode and the ground 
Calculating the capacitance requires taking the imaginary part of the total current  
(add the conduction and displacement current in the electrode) divided by the voltage,  
and then dividing it by the angular frequency w. 

Note Adjust the display precision control on the Results page to 15 significant digits  
voltage = 1 
frequency = 1e5 
 
    -1.283726057337429e-009 + 9.5180883490292279e-009  = 8.2343622916917989e-009 
                       voltage 
    and 
 
     8.2343622916917989e-009 = 1.3105394619322571e-014 
           2πf 

Calculate the conductance through the lossy dielectric substrate 
Calculating the conductance requires taking the real part of the total current  
(add the conduction and displacement current in the electrode) and then dividing it  
by the voltage. 

voltage = 1 
   
    4.867709461942146e-008 + 2.6640570893869313e-010 = 4.894350032836015e-008 
                      voltage 
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Parameterization 
Parameterizing the solution frequency 

Here we will use parameterization to study the behaviour as a function of frequency. 

 

1. From the Object page, select the model (i.e. TH-Microstrip.en). 
2. On the Edit menu, click Properties. 

The model properties dialog appears. 
3. Click the “Parameters” tab. 
4. Scroll down to the SourceFrequency parameter. 
5. In the Expression column, highlight 100000%Hz and then insert the following values: 

1, 1e4, 1e5, 1e6, 1e7, and 1e8. 
6. Press Tab. 
7. Click OK. 

Generating the time-harmonic field solution after parameterization 

Solve the model 
 On the Solve menu, click Time Harmonic 2D. 

The ElecNet Time-Harmonic 2D Solver Progress dialog appears briefly and then the Results 
window opens. 
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Analyzing the results after parameterization 
Graph the conduction and displacement current as a function of frequency 
The Results window is automatically displayed when the Solver Progress dialog closes and the 
solution is complete. The effect of having parameterized Source Frequency with several values 
has created a multiple-problem analysis. The procedure that follows uses Prob 1 as an example. 

 

1. In the Results window, open the “Conduction Current” page for Problem 1. 
2. Using the mouse pointer, click the Real value (i.e. 4.8902831050059879e-008) inside the 

Electrode (Strip) text box. 
3. Click the Graph Selection button, located at the top of the Results window. 

The graph should look like the illustration below. 
Note If required, adjust the display precision control on both Charts, illustrated below, to 

15 significant digits to display the same values as shown in the image below. 

 

4. In the Results window, open the “Displacement Current” page for Problem 1. 
5. Using the mouse pointer, click the Real value (i.e. 2.7468497902597885e-020) inside the 

Electrode (Strip) text box. 
6. Click the Graph Selection button, located at the top of the Results window. 

The graph should look like the illustration below. 

 
7. On the File menu, click Save. 
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Reconfiguring the problem to perform a transient analysis 
Removing the parameterization of the solution frequency 
Before proceeding with the transient analysis, we will remove the values assigned to 
SourceFrequency. This will, in effect, return the tutorial to a single-problem analysis.  

1. From the Object page, select the model (i.e. TH-Microstrip.en). 
2. On the Edit menu, click Properties. 

The model properties dialog appears. 
3. Click the “Parameters” tab. 
4. Scroll down to the SourceFrequency parameter. 
5. In the Expression column, highlight the following values: 

1, 1e4, 1e5, 1e6, 1e7, and 1e8. 
6. Press Delete. 
7. Click Close. 

Set the start, stop and step times 
The start, stop, and step times are defined in the Set Transient Options dialog. 

Note The transient solver assumes the source values before the start time are equal to the 
values at the start time only if the parameter SourcesOnAtTransientStart is set to Yes.  

1. On the Solve menu, click Set Transient Options. 
The Transient Options dialog appears. 

 

2. Make sure that Fixed Interval is selected as the Time Step method and Milliseconds as the 
unit for time, and then make the following modifications for Time: 

 Start = 0.0  
 Stop = 0.06  
 Step = 0.0001  

3. Click “Sources are on when solving starts” to set the SourcesOnAtTransientStart parameter 
to Yes. 

4. Click OK. 
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Defining a pulse waveform for the electrode 

 

1. On the Project Bar, select the “Electrode” tab. 
2. Place the cursor over Electrode (Strip) item and then right-click the mouse. 
3. On the floating menu, click Properties. 

The Properties dialog appears. 
4. Select the Waveform tab. 
5. In the Type drop-down list, select Pulse. 
6. Click the P checkbox to enable Period in seconds and all preceding optional values. 
7. Insert the following values in the appropriate box: 

 V1 --> 0 
 V2 --> 1 
 Td --> 0 
 Tr --> 1e-6 
 Tf --> 1e-6 
 W --> 5e-6 
 P -->  1e-5 

8. Click OK. 

Solve 
 On the Solve menu, click Transient 2D. 

The ElecNet Transient 2D Solver Progress dialog appears for a few seconds and then the 
Results window opens. 
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View the solution results 

The following results will be reviewed in this section: 

 A graph of the conduction current versus time 

 A graph of the displacement current versus time 

Graph the conduction and displacement current versus time 

The Results window is automatically displayed when the Solver Progress dialog closes and the 
solution is complete. The Time Steps can be viewed by clicking the Time drop-down list box (as 
shown). 

 

1. In the Results window, open the “Conduction Current” page. 
2. Using the mouse pointer, click anywhere inside the Electrode (Strip) text box. 
3. Click the Graph Selection button, located at the top of the Results window. 

The graphs that follow should look like the illustrations below once you have adjusted the 
display precision control on the Charts to 15 significant digits to display the same values. 

 

4. In the Results window, open the “Displacement Current” page. 
5. Using the mouse pointer, click anywhere inside the Electrode (Strip) text box. 
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6. Click the Graph Selection button, located at the top of the Results window. 
The graph should look like the illustration below. 

 

Note The total current can be obtained by adding the displacement current with the 
conduction current. 

Save the model 

You have now completed the 2D Time Harmonic and 2D Transient tutorial. 

1. On the File menu, click Save. 
2. On the File menu, click Close. 

Summary 

In this tutorial, you completed the steps in creating a microstrip model for time-harmonic and 
transient solutions. The skills you learned include: 

 Setting up the work environment by modifying initial settings, the construction grid, and 
the viewing area. 

 Building the geometric model using the Keyboard Input Bar. 
 Setting up the problem -- this consists of making components and electrodes, using 

parameterization, and assigning boundary conditions. 
 Modifying the model to obtain the desired solution results. 
 Generating the time-harmonic field solution using ElecNet’s 2D Time-harmonic solver. 
 Generating the transient field solution using ElecNet’s 2D Transient solver. 
 Analyzing the results, which includes:  

 viewing the contours of V at 0’ 

 calculating the conductance and capacitance in the electrode 

 graphing the conduction and displacement current as a function of frequency and time 
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Modeling plan 

This problem consists of a substrate, a microstrip, a ground plane, and an air box. 

 

Creating a new model 

Opening a new model 
 From your desktop, double-click the ElecNet icon. 

The Main window appears. 
or 

 If ElecNet is already running, on the File menu, click New to open a new model. 

Name the model 

By default, ElecNet assigns a name to the model (e.g., ElecNet1) every time a new model is 
opened. As long as the application remains open, each new model number increments by one 
(e.g., if the new model you have opened is the fourth one in this session, ElecNet would assign 
the name ElecNet4). You can choose to retain this name, although it is recommended that you 
give the model a distinct name. 

1. On the File menu, click Save As. 
2. In the Save As dialog box, enter Microstrip as the name of the model. 
3. Choose the drive and directory where you want to place the model. 
4. Click Save As. 
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Setting up the working environment 
Initial Settings 

Each new model reverts to the ElecNet default settings for the meshing method, preferred units 
for length, time and frequency, and for how curves will be displayed in the view. For our model, 
we are going to change only the preferred unit for length and accept all the other defaults. 

1. From the Object page, select the model. 
2. On the Edit menu, click Properties. 
3. Select the Units tab. 
4.  From the Length drop down list, select Microns. 
5. Click OK. 

Set view to update automatically 

Use of this feature resets the view automatically to include all of the model’s geometry, as it is 
being drawn. 

 On the View menu, click Update Automatically. 

Build the geometric model and set up the problem for the 
substrate component 
Draw the substrate component 
1. On the Tools menu, click Keyboard Input Bar. 
2. On the Draw menu, click Line. 
3. In the Keyboard Input bar, enter the following coordinates to draw the substrate: 

Start coordinates -4500, 0 Press ENTER 

End coordinates   5500, 0 Press ENTER 

End coordinates   5500, 1000 Press ENTER 

End coordinates -4500, 1000 Press ENTER 

End coordinates -4500, 0 Press ENTER 

4. Press ESC. 

Make the substrate component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name:  Substrate 

 Material: EPE1: Relative permittivity 10 

 Distance: 10000 Microns 

4. Click OK. 
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5. From the Object page, select the Substrate component. 
6. On the Edit menu, click Properties. 
7. Select the Mesh tab. 
8. Click the Maximum Element Size checkbox and then type 500 in the text box. 

Verify that units are in Microns. 
9. Select the Parameters tab. 
10. Scroll down to PolynomialOrder and type 2 in the Expression text box. 
11. Click OK. 

Set the electric conductivity of the material “EPE1” 
1. In the Project Bar, select the Material tab. 
2. Select “EPE1: Relative Permittivity 10” in the Model Materials database. 

 

3. Right-click and then select Properties. 
The “EPE1: Relative Permittivity 10” Properties dialog appears. 

4. Select the “Electric Conductivity” tab. 
5. In the Conductivity Siemens/m column, type 1e-4 and then press Tab. 

The value for %IACS is automatically generated. 

 

6. Click OK. 
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Assign boundary conditions to the substrate 

 

1. On the View menu, click Examine Model Dynamically. 
2. Place and hold the cursor over the model and rotate upward until it appears similar to the 

sample above. 
3. In the Object page, select Face#3 of the Substrate component. 

The bottom surface of the substrate is selected. 
4. On the Boundary menu, click Ground. 
5. Repeat procedures 3 (substituting Face#3) and 4 for Face#4 and then Face#6. 

Move the construction slice to draw the microstrip 

Move the construction slice 
1. In the Object page, select Face#5 of the Substrate component. 
2. On the Draw menu, click Move Construction Slice. 
3. Ensure that the “To the currently selected surface” option is selected, and click OK. 
4. On the Draw menu, click Move Construction Slice. 
5. Select the “Along an arc” option and enter the following values, if required: 

 Angle: 180 degrees 

 Center: (0, 0) Microns 

 Axis vector: (0, -1) 

6. Click OK. 
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Delete construction slice edges 

Since the edges on the construction slice remain even after being swept into a component, we 
must remove them before proceeding to the next step of the tutorial. 

1. On the Edit menu, click Select Construction Slice Edges. 
2. On the Edit menu, click Select All. 
3. Press the Delete key. 

Build the geometric model and set up the problem for the 
microstrip component 

Draw the microstrip component 

 

1. On the View menu, click Wireframe Model. 
2. On the View menu, click Preset Views, and then click Negative Y Axis. 
3. On the Draw menu, click Line. 
4. In the Keyboard Input bar, enter the following coordinates to draw the microstrip: 

Start coordinates 0, 0 Press ENTER 

End coordinates 0, 9500 Press ENTER 

End coordinates 1000, 9500 Press ENTER 

End coordinates 1000, 0 Press ENTER 

End coordinates 0, 0 Press ENTER 

5. Press ESC. 
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Make the microstrip component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name:      Strip 

 Material:  AIR 

 Distance:    0 Microns 

4. Click OK. 
5. From the Object page, select the Strip Face#1 (Start face) surface. 
6. On the Edit menu, click Properties. 
7. Select the Mesh tab. 
8. Click the Maximum Element Size checkbox and then type 100 in the text box. 

Verify that units are in Microns. 
9. Click OK. 

Make an electrode 
1. In the Object page, select Strip component. 
2. On the Model menu, click Make Electrode. 
3. In the Object page, select Electrode #1. 
4. On the Edit menu, click Properties and modify Electrode#1 to read: 

 Name:    Electrode (Strip) 

5. Select the Waveform tab and enter the following values for ACDC: 

 Magnitude (RMS): 0.000707107 
Phase (Deg):                          0  

6. Click OK. 

Move the construction slice to draw the boundaries 

Move the construction slice 
1. In the Object page, select Face#1 (Start Face) of the Substrate component. 
2. On the Draw menu, click Move Construction Slice. 
3. Ensure that the “To the currently selected surface” option is selected, and click OK. 

Delete construction slice edges 

Since the edges on the construction slice remain even after being swept into a component, we 
must remove them before proceeding to the next step of the tutorial. 

1. On the Edit menu, click Select Construction Slice Edges. 
2. On the Edit menu, click Select All. 

Make sure that the View window is the active window. 
3. Press the Delete key. 
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Build the geometric model and set up the problem for the air 
box component 
Draw the air box component 
1. On the View menu, click Preset Views, and then click Positive Z Axis. 
2. On the Draw menu, click Line. 
3. In the Keyboard Input bar, enter the following coordinates to draw the air box: 

Start coordinates -4500, 1000 Press ENTER 
End coordinates  5500, 1000 Press ENTER 
End coordinates  5500, 11000 Press ENTER 
End coordinates -4500, 11000 Press ENTER 
End coordinates -4500, 1000 Press ENTER 

4. Press ESC. 

Make the air box component 
1. On the Edit menu, click Select Construction Slice Surfaces. 
2. Select the interior region of the model you have drawn. 
3. On the Model menu, click Make Component in a Line, and enter the following values: 

 Name:   Air box 
 Material: AIR 
 Distance: 10000 Microns 

4. Click OK. 
5. From the Object page, select the Air box component. 
6. On the Edit menu, click Properties. 
7. Select the Parameters tab. 
8. Scroll down to PolynomialOrder and type 2 in the Expression text box. 
9. Click OK. 

Assign boundary conditions to the air box 

 

1. On the View menu, click Solid Model. 
2. On the View menu, click Examine Model Dynamically. 
3. Place and hold the cursor over the model and rotate upward until it appears similar to the 

sample above. 
4. In the Object page, select Face#4 of the Air box component. 
5. On the Boundary menu, click Ground. 
6. Repeat procedures 3 and 4 for Face#5 and Face#6. 
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Modifying the model prior to solving 
Create new slices for X=500 and Z=0 

In this procedure, we are going to create two new slices, with one running through the microstrip 
component (X=500), and the other perpendicular to it (Z=0). This will allow us to view the field 
plot for each slice. 

Note Slices are only visible in a solution mesh. 
1. On the Tools menu, click New Slice. 
2. Select the “Based on the point-normal definition of a plane” option, and enter the following 

data: 
 Point in the slice:    (500, 0, 0) Microns 
 Normal on the slice:  (1, 0, 0) 

3. Click OK. 
The slice (i.e. Slice#1) for X=500 is created. 

4. On the Tools menu, click New Slice. 
5. Select the “Based on the point-normal definition of a plane” option, and enter the following 

data: 
 Point in the slice:    (0, 0, 0) Microns 
 Normal on the slice:  (0, 0, 1) 

6. Click OK. 
The slice (i.e. Slice#2) for Z=0 is created. 

Generating the electrostatic field solution 

Set the solving options 
1. On the Solve menu, click Set Solver Options, and verify that the following values are set: 

 Material type:  Non-linear 
 Method: Newton-Raphson 
 Maximum Newton iterations: 20 
 Newton tolerance: 1 % 
 CG tolerance:  0.01 % 
 Source frequency: 1e5 Hertz 

Note CG Tolerance is the only value that has any significance for electrostatic 
solutions. All other values are listed for information purposes only. 

2. Click OK. 

Solve the model 
 On the Solve menu, click Static 3D. 

The Static 3D Solver Progress dialog appears briefly and then the Results window opens. 
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Analyzing the results 
In this section, the following results are viewed: 

 Contours of V and shaded plot of |E| smoothed at Z=0 
 Contours of V and shaded plot of |E| smoothed at X=500 

Hide all the components 
Hiding all of the components and the boundary conditions will allow us to view the fields on the 
two slices. 

 

1. On the Object page, keeping the Shift key down, first select Substrate and then select 
BoundaryCondition#6 (G). 
All the required components and boundary conditions are selected. 

2. On the Edit menu, click Toggle Visibility of Selected Components. 
3. The  symbol appearing next to each component object indicates that they are hidden. 

Set the color interpolation and style of the shaded plot 
This procedure will set the default for shaded plots to smooth instead of discrete, which is the 
default. 
1. On the View menu, click Default Fields. 
2. On the Project Bar, select the View tab. 
3. From the View tree, click Shaded Plot. 
4. On the Edit menu, click Properties. 

The Shaded Plot Properties page appears.  

 

5. Click the Styles tab and then from the Interpolation drop-down menu, select  
"Smooth: Displays blended colors between field values". 

6. Click OK. 
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View the contours of V and shaded plot of |E| smoothed 

Since V and |E| smoothed are the default fields for ElecNet, this procedure is pretty 
straightforward. To plot these fields on the slice we created will require only one additional step, 
that is, changing the view for X=500. 

    

1. Before viewing the contour and shaded plots, switch back to the View window by clicking 

the View tab  located at the bottom of the window. 
2. On the View menu, click Preset Views, and then click Positive Z Axis. 
3. From the Project Bar, select the “Field” page. 

The page appears with the “Contour” tab selected. 
4. In the “Fields to Display” box, verify that V is selected. 

Optionally, you can select the Shaded tab and verify that |E| smoothed is selected. As 
mentioned above, since both fields are the defaults, this step is for verification purposes, 
only. 
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5. At the bottom of the Field page, click Update View. 
The view of the combined fields (contours of V and the shaded plot of |E| smoothed) at Z=0 
is displayed. 

 

Note The boundary of the electrode represents a singularity – the more the boundary is 
refined, the higher |E| will be. 

6. On the View menu, click Preset Views, and then click Positive X Axis. 
The view of the combined fields (contours of V and the shaded plot of |E| smoothed) at 
X=500 is displayed. 

 

Note The boundary of the electrode represents a singularity – the more the boundary is 
refined, the higher |E| will be. 
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Generating streamlines  
The following procedure demonstrates how the Streamline Generator extension can be used to 
create "Flux function" contour plots (i.e. streamlines) in a 3D model. 
1. On the Object page, keeping the Ctrl key down, first select Substrate and then select Strip. 
2. On the Edit menu, click Toggle Visibility of Selected Components. 

A  symbol appears next to the selected components to signify that they are now visible. 
3. On the View menu, click Solid Model. 
4. On the View menu, click Examine Model Dynamically. 
5. Place and hold the cursor over the model and rotate it until it appears similar to the sample 

below. 

 

6. On the Extensions menu, click Streamline generator. 
The Streamline Generator extension appears. 

 

7. Select the Maximum |E| or |J| tab. 
8. Click Generate. 

Streamlines are generated using seed points that are the coordinates of the points in the 
solution where maximum |E| occurs, as shown (red line) in the illustration below. 

 

The report displays the following information: 
Start of streamline generation... 
Getting the field for generating the streamlines. 
Seed #1 of 1: (1000, 1000, 9500). 
End of streamline generation. 
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9. Select the Point & Chart tab. 
10. Using the coordinates [i.e. Seed #1 of 1: (1000, 1000, 9500)] listed in the report, enter these 

values in the X, Y, and Z text boxes, and make sure that “Automatically create charts of the 
fields along the streamline” is checked . 

11. Click Generate. 
Since we are using the same seed points, an identical streamline path to the one generated for 
Maximum |E| is produced. In addition to the streamlines, charts showing the field values of 
“Voltage (V) vs Distance (μ)” and “|E| (V/m) vs Distance (μ)” along streamlines (1000, 
1000, 9500) are displayed.  

 

Voltage (V) vs Distance (μ) chart 

 

|E| (V/m) vs Distance (μ) chart 

12. Click Clear to remove the streamlines from the model and then click Close to exit the 
Streamline Generator extension. 

13. Close the Chart window and then maximize the model view. 
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Reconfiguring the problem to perform a transient analysis 
Set the start, stop and step times 

The start, stop, and step times are defined in the Set Transient Options dialog. 

Note The transient solver assumes the source values before the start time are equal to 
the values at the start time only if the parameter SourcesOnAtTransientStart is set 
to Yes.  

1. On the Solve menu, click Set Transient Options. 
The Set Transient Options dialog appears. 

 

2. Make sure that Fixed Interval is selected as the Time Step method and Milliseconds as the 
unit for time, and then make the following modifications for Time: 

 Start = 0.0  

 Stop = 0.06  

 Step = 1e-3  

3. Click “Sources are on when solving starts” to set the SourcesOnAtTransientStart parameter 
to Yes, if required. 

4. Click OK. 

Defining a pulse waveform for the electrode 
1. On the Object page, keeping the Shift key down, first select Air box and then select 

BoundaryCondition#6 (G). 

 

2. On the Edit menu, click Toggle Visibility of Selected Components. 
A  symbol appears next to the selected items to signify that they are now visible. 
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3. On the Project Bar, select the “Electrode” tab. 
4. Place the cursor over Electrode (Strip) item and then right-click the mouse. 
5. On the floating menu, click Properties. 

The Electrode properties dialog appears. 
6. Select the “Waveform” tab. 

 

7. In the Type drop-down list, select Pulse. 
8. Click the P checkbox to enable Period in seconds and all preceding optional values. 
9. Insert the following values in the appropriate box: 

 V1 --> 0 
 V2 --> 1 
 Td --> 0 
 Tr --> 1e-6 
 Tf --> 1e-6 
 W --> 5e-6 
 P -->  1e-5 

10. Click OK. 

Solve 
 On the Solve menu, click Transient 3D. 

The ElecNet Transient 3D Solver Progress dialog appears for a minute or two and then the 
Results window opens. The Solver Progress dialog automatically exits when the solution is 
complete. 
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View the solution results 

The following results will be reviewed in this section: 

 A graph of the conduction current versus time 

 A graph of the displacement current versus time 

Graph the conduction and displacement current versus time 

The Results window is automatically displayed when the Solver Progress dialog closes and the 
solution is complete. The Time Steps can be viewed by clicking the Time drop-down list box 
(highlighted in the image below). 

 

1. In the Results window, open the “Conduction Current” page. 
2. Using the mouse pointer, click anywhere inside the Electrode (Strip) text box. 
3. Click the Graph Selection button, located at the top of the Results window. 

The graph should look like the illustration below. 

 

4. In the Results window, open the “Displacement Current” page. 
5. Using the mouse pointer, click anywhere inside the Electrode (Strip) text box. 
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6. Click the Graph Selection button, located at the top of the Results window. 
The graph should look like the illustration below. 

 

Note The total current can be obtained by adding the displacement current with the 
conduction current. 

Save the model 

You have now completed the 3D Transient portion of the tutorial. 

1. On the File menu, click Save. 
2. On the File menu, click Close. 

Summary 

In this tutorial, you completed the steps in creating a microstrip model for electrostatic and 
transient solutions. The skills you learned include: 

 Setting up the work environment by modifying initial settings and the viewing area. 
 Building the geometric model using the Keyboard Input Bar. 
 Setting up the problem -- this consists of making components and electrodes, and 

assigning boundary conditions. 
 Modifying the model so as to obtain the desired solution results. 
 Generating the electrostatic and transient field solution using ElecNet’s 3D Electrostatic 

and Transient solvers. 
 Generating streamlines using Infolytica’s Streamline Generator extension. 
 Analyzing the results, which includes viewing the contours of V and the shaded plot of 

|E| smoothed, from two viewing perspectives (Z=0 and X=500). 
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